All for Joomla All for Webmasters
Your address will show here +12 34 56 78

Home Forums TF8 Midi learn ref chapter 4.4.4. page 23 manual.

This topic contains 4 replies, has 2 voices, and was last updated by  Pier 4 days, 1 hour ago.

  • Creator
    Topic
  • #2070

    werd
    Participant

    Hi, question, i am not able to control TF8 midi learn function with app midiLFO, both apps standalone after reboot Ipad Air2, IOS 103.1. Setup: MidiLfo (background mode on, midi routing > TF8 destination ch#1 CC#7; TF8 config CH 1 midi input MidiLFO selected. Control selected volume slider, press learn,
    TF8 does not recognize midiLFO CC. Does this mean that TF8 only listen to hardware midi controllers at this moment? cheers, Richard

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #2072

    Pier
    Keymaster

    Hi Werd,

    By right it should listen to software midi controllers. Let me check and get back to you.
    Thanks for highlighting.

    #2074

    Pier
    Keymaster

    Hi Werd,

    I wasn’t able to get in touch with the developer of MidiLFOs to get a testing promo code, but I went ahead and purchased it anyway.
    I was able to get it to work, but it’s kind of awkward because of the way midiLFO works. It seems to keep sending midi data continuously, confusing the midi learning functionality in TF8. (please correct me if I am wrong). If there were a start/stop button things would be easier.

    Here are the steps to get it working.

    1. Go to TF8 > Config > Midi : Uncheck all the midi inputs except midiLFOs. This means we are only using the midiLFO source input. I left the channels at omni.
    2. Launch MidiLFOs. Select none for the midi destination for ALL the LFOs. (you will change this later)
    3. Go to TF8 > Config > Control : Press on the Midi CC you want to use. Say, Volume which is a slider. Press “Learn”.
    4. Here is where it gets tricky. Go to Midi LFO, select the MidiLFO that you want and switch its source input to midiLFOs out. This will start sending midi data to the channel midiLFO, which TF8 is currently listening and attempting to learn from.
    5. Switch back to TF8. You will see that the midi CC has been “learnt”.
    6. If all goes well, you should see in the Main screen of TF8 that the volume knob is sliding back and forth.

    The gist is that the TF8 midi cc learn functionality is designed to listen to knobs that were not moving continuously. (which is the normal behaviour of physical knobs)
    Unfortunately, this does seem to suggest that everytime you need to “learn” a midiLFO, you need to change the destination of ALL the midiLFOs to NONE, and repeat the above.
    Granted, I’ve found that my clear functionality in the midi CC screen doesn’t seem to clear the midi cc visual. It shouldn’t stop you from having fun with midiLFO though. This is a bug and will be fixed.

    Hope it works for you!

    Pier.

    • This reply was modified 1 week, 3 days ago by  Pier.
    • This reply was modified 1 week, 3 days ago by  Pier.
    • This reply was modified 1 week, 3 days ago by  Pier.
    • This reply was modified 1 week, 3 days ago by  Pier.
    #2079

    werd
    Participant

    Hi Pier, thanks so much for your support, but the workaround did not work for my Ipad and TF8. However I did a test with midiLFO and your Synth TF7 and it works. Perhaps you can look into this matter again in your plans for a universal version in the future. Kind regards Richard

    IOS 10.3.1 /Ipad Air 2 reboot, workaround midiLFO /synth TF7.
    -Launch midiLFO set output on NONE 4x, exit
    -Launch midiLFO (standalone), Launch TF7 (standalone)
    -switch to TF7 settings midi ch omini midiLFO, midi CC mapping select Tone, Mod1-Index, press learn, press move Ctrl
    -switch to midiLFO, set status NONE to TF7 (ch#1 CC#7)
    -switch to LFT7 Mod1-Index recognizes ch#1 en CC#7 and slider moves.

    -switch back to midiLFO change status TF7 to NONE
    -switch to TF7 select Tone view, the slider doesn’t move anymore, select Mix Slider ch@1 /CC#7, Clear (fleld is empty)

    -select Mod1-Modulation amount slider, press LEARN, press move ctrl
    -swith to midiLFO, set status NONE to TF7, Midi CC en CH show up and in Tone view the modulation amount slider moves.

    #2080

    Pier
    Keymaster

    Hi Werd,

    Verified that you are right. It works on iPhone but not iPad, which is strange! I will have to look into it.
    Previously I was trying it out using iPhone.
    Will fix this in the next update.

    Thanks for the heads up.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.